Product Guides: 360-Degree Feedback

Operating System Requirements

For an optimal, secure user experience, we recommend accessing EchoSpan on a computer running one of the two most recent releases of Windows or Mac operating systems. EchoSpan may function with older Windows and Mac operating systems, but certain features may not perform as well.

If you see some unexpected behavior, you may want to switch to a supported operating system and verify that JavaScript is enabled on your browser.


Last updated: Wednesday, January 18, 2017
108
operating systems, windows, mac, technical requirements
Our website uses cookies
Cookies enable us to provide the best experience possible and help us understand how visitors use our website. By browsing EchoSpan, you agree to our use of cookies.
I Understand More Info